FS S3700-24T4F VLAN CLI 24-Port Gigabit Ethernet L2 Switch User Guide
- October 30, 2023
- FS
Table of Contents
FS S3700-24T4F VLAN CLI 24-Port Gigabit Ethernet L2+ Switch
Product Information: VLAN CLI Reference Guide
The VLAN CLI Reference Guide is a user manual for the S3700-24T4F switch model. This guide provides detailed instructions and information on how to configure VLANs using the Command Line Interface (CLI) on the S3700-24T4F switch. The S3700-24T4F switch is a layer 2 switch that is designed for small to medium-sized businesses.
Product Features:
- 24 10/100/1000BASE-T ports
- 4 Gigabit SFP ports
- Layer 2 switching
- Supports VLANs and VLAN tagging
- CLI management interface
Product Usage Instructions:
To configure VLANs using the CLI on the S3700-24T4F switch, follow these steps:
- Connect to the switch using a console cable and a terminal emulation program, such as PuTTY.
- Log in to the switch using your username and password.
- Enter the VLAN configuration mode by typing “vlan” and pressing enter.
- Create a new VLAN by typing “vlan [vlan-id]” and pressing enter. Replace “[vlan-id]” with the desired VLAN ID number.
- Add ports to the new VLAN by typing “port vlan [vlan-id] [port-number]” and pressing enter. Replace “[vlan-id]” with the VLAN ID number you created in step 4, and replace “[port-number]” with the number of the port you want to add to the VLAN.
- Repeat steps 4 and 5 to create and configure additional VLANs as needed.
- Save your changes by typing “save” and pressing enter.
For more detailed instructions and information on configuring VLANs using the CLI on the S3700-24T4F switch, refer to the VLAN CLI Reference Guide.
VLAN Configuration Commands
VLAN Configuration Commands
The VLAN configuration commands include:
- vlan
- name
- dot1g-tunnel
- switchport pvid
- switchport mode
- switchport trunk
- show vlan
- show interface vlan
vlan
Syntax
[nol vlan vlan-id
To add a VLAN, run vlan vlan-id. To delete a VLAN, run [no] vlan vlan-id.
Parameters
Default Value
The default value is 1.
Command Mode
Global configuration mode
Usage Guidelines
After this command is run, the system enters the VLAN configuration mode and
then you can
modify some VLAN attributes.
Example
The following example shows how to add the VLAN whose ID is 2:
Switch_config#
Switch_config#van 2
Switch_config_vlan2#exit
name
Syntax
To name a VLAN, run name str.
[no] name str
Parameters
Default Value
The default VLAN name is ‘Default’. Other VLAN’s name is VLANxxxx (xxxx is
4-digit stack ID)
Command Mode
VLAN configuration mode
Usage Guidelines
This command can be used to modify the VLAN name to symbolize a specific VLAN.
Example
The following example shows how to set the name of VLAN200 to main405:
Switch_config#
Switch_config#
Switch_config#vlan 200
Switch_config_vlan200#name ?
WORD The ascii name of VLAN(32bytes)
Switch_config_vlan200#name main405
dot1g-tunnel
Syntax
dot1g-tunnel
no dot1q-tunnel
To enable or disable the Dot1q tunnel globally, run the following commands.
Parameters
None
Default Value
Dot1q Tunnel is not enabled globally.
Command Mode
Global configuration mode
Usage Guidelines
After Qot1Q Tunnel is globally enabled, all ports serve as the downlink ports
of Qot1Q Tunnel by
default and put the SPLAN tag on the incoming packets.
Example
The following example shows how to enable Dot1q tunnel in the global
configuration mode.
Switch_config#dot1q-tunnel
switchport pvid
Syntax
To configure VLAN of the access-mode port, run switchport pid vlan-id.
switchport pvid vlan-id
no switchport pvid
Parameters
Default Value
All ports belong to VLAN 1.
Command Mode
Port configuration mode
Usage Guidelines
If vlan which pvid belongs does not exist before the command, it will be
created with the creation of pvid. The port can be configured in the access
mode or the relay mode.
Example
The following example shows how to set port Gigathernet 0/1 to the access port
of VLAN10:
Switch_config#interface g0/1
Switch_config_g0/1#switchport pvid 10
switchport mode
Syntax
switchport mode (access | trunk | dot1q-tunnel-uplink | dot1q-translating
tunnel no switchport mode
To configure the mode of the port, run the following command.
Parameters
Default Value
Access mode
Command Mode
Port configuration mode
Usage Guidelines
The switch’s port supports the following modes: the access mode, the relay
mode, the VLAN tunnel mode, the VLAN translating tunnel mode and the VLAN
tunnel uplink mode. The access mode indicates that the port belongs to just
one VLAN; only the untagged Ethernet frame can be transmitted and received.
The relay mode indicates that the port connects other switches and the tagged
Ethernet frame can be transmitted and received. The VLAN translating tunnel
mode is a sub mode based on the relay mode. The port looks up the VLAN
translation table according to the VLAN tag of received packets to obtain
corresponding SPVLAN, and then the switching chip replaces the original tag
with SPVLAN or adds the SPVLAN tag to the outside layer of the original tag.
When the packets is forwarded out of the port, the SPVLAN will be replaced by
the original tag or the SPVLAN tag will be removed mandatorily. Hence, the
switch omits different VLAN partitions that access the network, and then
passes them without change to the other subnet that connects the other port of
the same client, realizing transparent transmission. The VLAN tunnel uplink
mode is a sub mode based on the relay mode. The SPVLAN should be set when
packets are forwarded out of the port. When the packets are received by the
port, their TPIDs will be checked. If difference occurs or they are untagged
packets, the SPVLAN tag which contains their own TPID will be added to them as
their as outer-layer tag. When the packets are receied by the port, their
TPIDs will be checked. If difference occurs or they are untagged packets, the
SPLAN tag which contains their own TPID will be added to them as their outer-
layer tag. The port mode collides with the 802.1X protocol. The 802.1X
protocol cannot be configured in relay mode (including the VLAN translating
tunnel mode and the VLAN tunnel uplinkv mode); the port on which the 802.1X
protocol is configured cannot be set to the relay mode. That is to say, the
802.1X protocol can be effective only on the access-mode port (including the
VLAN tunnel mode). The 802.1X standard does not support authentication on the
trunk port. The reason is that the authentication object regulated in the
standard is not the port. As to port multiplexing, if user authentication is
approved in one VLAN, all other VLAN users who multiplex this port are also
authorized correspondingly, therefore, the trunk port does not support
authentication.
Example
The following example shows how to configure the port to VLAN tunnel uplink
port mode.
Switch_config_g0/1#switchport mode dot1q-tunnel-uplink
switchport trunk
Syntax
To configure the attributes of the relay port, run the following command.
(no] switchport trunk [ (vlan-allowed vlan-list | (vlan-untagged vlan-list} }
Parameters
Default Value
The native VLAN ID of all relay ports is 1. The allowable value for all VLANs
ranges between 1 and 4094.
Command Mode
Port configuration mode
Usage Guidelines
No matter the port is in access mode or in relay mode, you can run this
command on the port. However, the port is in relay mode when this command
functions. The vlan-allowed parameter is used to control the VLAN range of the
port; the vlan-untagged parameter is used to decide which packets need be
added with the VLAN tag when a port transmits these packets. When the vlan
list is used, you can add, remove or set (none, all, except) the lists of the
existinqVLAN. The entered lists are separated by the comma or the hyphen. For
example, “1, 3, 5, 7′ stands for “vlan 1, vlan 3, vlan 5, vlan 7”, while “1,
3-5, 7” stands for “van 1, vlan 3, vlan 4, vlan -5, vlan 7”
Example
The following example shows how to set the allowable VLAN range to 1-10, and
the untagged VLAN range to 2-1000.
Switch_config_g0/1#switchport trunk vlan-allowed 1-10
Switch_config_g0/1#switchport trunk vlan-untagged 2-1000
show vlan
Syntax
To display relative information about all VLANs, run the following command.
show vlan [ id vlan-id | interface intfid | dot1q-tunnel [interface intf Imac-
vlan | subnet I protocol-vlan dot1q-translating-tunnel flat-translation-table]
Parameters
Default Value
None
Command Mode
Global configuration mode, port configuration and EXEC configuration mode
Usage Guidelines
None
Example
The following example shows how to display relative information about all
VLANs.
Switch#show vlanThe status parameter stands for the
VLAN generation source; the static parameter means that VLAN is generated
through configuration; the dynamic parameter means that VLAN is generated
dynamically through the GVRP protocol.
The following example shows the detailed information about a VLAN: Switch#show
vlan id 1
The following example shows relative information about alLANon a port:
Switch#show van int g0/6
show interface vlan
Syntax
To display relative information about the VLAN interface, run the following
command. show interface vlan intf-id
Parameters
Default Value
None
Command Mode
Global configuration mode, port configuration and EXEC configuration mode
Usage Guidelines
None
Example
The following example shows how to display the information about interface
VLAN 1.
Switch#show int vlan
VLAN1 is up, line protocol is up
Hardware is EtherSV1, Address is 00e0.0f42.0071(00e0.0f42.0071)
MTU 1500 bytes, BW 1000000 kbit, DLY 2000 usec
Encapsulation ARPA, loopback not set
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 multicasts
0 input errors, 0 input discards
0 packets output, 0 bytes, 0 underruns
Transmited 0 broadcasts, 0 multicasts
0 output errors, 0 discards
ARP type: ARPA, ARP timeout 04:00:00
The statistics values are explained as follows:
Packets input means the input of all packets, including broadcast packets,
multicast packets and unicast packets. Bytes means the byte volume of all
packets. Broadcasts means received broadcast packets. Broadcasts means
received broadcast packets. Input errors means received error packets. Input
discards means that the received packets are dropped, such as the received
packets when the interface protocol is down. Packets output means the output
of all packets, including broadcast packets, multicast packets and unicast
packets. Bytes means the byte volume of all transmitted packets. Broadcasts
means transmitted broadcast packets. Multicasts means transmitted multicast
packets. Output errors means transmitting error packets. Output discards means
that the transmitted packets are dropped, such as the transmitted packets when
the interface protocol is down.
https://www.fs.com
The information in this document is subject to change without notice. FS has
made all efforts to ensure the accuracy of the information, but all
information in this document does not constitute any kind of warranty.
Copyright © 2009-2022 FS.COM All Rights Reserved.
References
Read User Manual Online (PDF format)
Read User Manual Online (PDF format) >>